miércoles, 26 de octubre de 2016

Dirty Cow vulnerabilidad del kernel Linux

Hola a todos, desde ayer 25 de octubre de 2016, sabemos que se ha detectado un bug en el kernel de linux al que han llamado Dirty COW. La vulnerabilidad afecta al 'Copy-On-Write' del sistema también popularmente llamado COW.

Esta vulnerabilidad podría utilizarse para tomar el control de un dispositivo que ejecute dicha versión de Linux (Android, ordenadores, servidores y también nuestra RaspberryPi).
La solución a esta vulnerabilidad ha sido solucionada y la podemos obtener actualizando el Kernel de nuestra Raspberry.

Para solucionar la vulnerabilidad Dirty-COW tenemos que abrir un terminal (pantalla de línea de comandos) y introducid las siguientes órdenes:

sudo apt-get update

y presionamos Intro en el teclado (esto va a tardar un poco, paciencia...), una vez haya acabado introducimos la segunda orden

sudo apt-get install raspberrypi-kernel

luego presionamos Intro en el teclado (esto también va a tardar un poquito más que la anterior). Una vez finalizado reiniciad la RaspberryPi. Ya estáis fuera de peligro.

Has ta pronto.